summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-02-22 07:34:44 +0000
committerDavid Schleef <ds@schleef.org>2002-02-22 07:34:44 +0000
commited91b8b7cbbc9fd9b1c6ed48ea261ea997c53d39 (patch)
tree314a37dc988601002272e5fabe488465666891b7 /debian
parente4e0b255f34dbce6630d56375ba7bf339a59ae52 (diff)
Build fix for arm
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules11
1 files changed, 10 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 72c028428..aeb33c89f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,7 +42,16 @@ build-stamp: debian/control
dh_testdir
# Brute force method of getting kernel headers
- tar --bzip2 -xf /usr/src/$(kernel_source).tar.bz2 $(kernel_source)/include
+ tar --bzip2 -xf /usr/src/$(kernel_source).tar.bz2 \
+ $(kernel_source)/include
+
+ # Hack to get include/asm-arm/arch directory. This should
+ # stay here, and not move to the top-level Makefile, since
+ # it adds a link _in the kernel source_, which is almost
+ # certainly wrong in most situations.
+#ifeq ($(target),arm)
+ ln -s arch-sa1100 $(kernel_source)/include/asm-arm/arch
+#endif
ifneq ($(target),mipsel)
cp extra/Configs/Config.$(target) Config