summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-04-13 20:58:16 +0000
committerDavid Schleef <ds@schleef.org>2002-04-13 20:58:16 +0000
commited44f35a1aa84c6e42dac46aab75e9f8fcc6d7b7 (patch)
treec0ac0eb629a4e0a6173f4fdfa95812016b152fdd /debian
parenteb3cd98ee3e3928ca2a00d7b661a32c5d2f1586f (diff)
use uClibc_config_fix.pl for configuration
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules41
1 files changed, 35 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index a17bff7d0..3f2d178df 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,10 +23,26 @@ with_shared_libs=y
#with_shared_libs=n
#endif
+ifeq ($(with_shared_libs),y)
+shared_libs_true=true
+else
+shared_libs_true=false
+endif
+
ifneq ($(target),$(DEB_HOST_GNU_CPU))
target_suffix=-$(target)
endif
+ifneq ($(target),mipsel)
+config_orig = extra/Configs/Config.$(target)
+else
+config_orig = extra/Configs/Config.mips
+endif
+
+ifneq ($(target),$(DEB_HOST_GNU_CPU))
+cross_options = --cross="$(target)-linux-"
+endif
+
p_dev=libuclibc-dev$(target_suffix)
p_lib=libuclibc0$(target_suffix)
p_gcc=uclibc$(target_suffix)-toolchain
@@ -56,12 +72,24 @@ build-stamp: debian/control
touch $(kernel_source)/include/linux/autoconf.h
-ifneq ($(target),mipsel)
- cp extra/Configs/Config.$(target) Config
-else
- cp extra/Configs/Config.mips Config
-endif
-
+ extra/Configs/uClibc_config_fix.pl \
+ --arch=$(target) \
+ $(cross_options) \
+ --devel_prefix=/usr/$(target)-linux-uclibc \
+ --kernel_dir=`pwd`/$(kernel_source) \
+ --large_file=true \
+ --rpc_support=true \
+ --c99_math=true \
+ --threads=true \
+ --long_long=true \
+ --float=true \
+ --shadow=true \
+ --ldso_path="/lib" \
+ --shared_support=$(shared_libs_true) \
+ --file=$(config_orig) \
+ >Config
+
+ifeq (yes,no)
echo '#Debian configuration overrides' >>Config
ifneq ($(target),$(DEB_HOST_GNU_CPU))
echo 'TARGET_ARCH = $(target)' >>Config
@@ -85,6 +113,7 @@ endif
echo 'DO_C99_MATH = true' >>Config
echo 'DODEBUG = false' >>Config
echo 'INCLUDE_THREADS = true' >>Config
+endif
mkdir -p lib