summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-08-09 23:01:39 +0000
committerDavid Schleef <ds@schleef.org>2002-08-09 23:01:39 +0000
commit5ebd661263e12344da578d2794363ef958d6b20e (patch)
treee0ce923a7a1716a96e6f6e2c73d1eb1c3c893e7d /debian
parentcbbea73abcb0124d4f7d7c3bde0ea4395374d401 (diff)
fix mksnapshot and update documentation.
Diffstat (limited to 'debian')
-rw-r--r--debian/README.Debian13
-rw-r--r--debian/changelog1
-rw-r--r--debian/docs4
-rwxr-xr-xdebian/mksnapshot15
4 files changed, 22 insertions, 11 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
index fd3919ead..53bac4647 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -1,12 +1,15 @@
-The script mksnapshot will automatically download a new snapshot
-from the uClibc CVS server.
-Notes on Build-Depends:
- kernel-headers | kernel-headers-2.4.10 autobuilt on i386 and powerpc
+Notes about building:
- kernel-headers-2.4 autobuilt on xxx
+The script mksnapshot will automatically download a new snapshot
+from the uClibc CVS server. This uses the uclinux.org anonymous
+CVS repository, which is a read-only mirror of the actual upstream
+repository.
+Building depends on the kernel-source-2.4.18 package. Doing this
+is really the most convenient way of getting kernel headers, and
+it works consistently on all architectures.
diff --git a/debian/changelog b/debian/changelog
index 060ec199b..58239b31d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ uclibc (0.9.11-cvs20020420-1) unstable; urgency=low
* Many of the configs have broken CROSS definitions. Compensate
for that in debian/rules.
+ * Install more documentation
-- David Schleef <ds@schleef.org> Sat, 20 Apr 2002 15:40:39 -0700
diff --git a/debian/docs b/debian/docs
index 724e08449..5460d353e 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,2 +1,6 @@
README
TODO
+Changelog.full
+BUGS
+docs/threads.txt
+docs/uclibc.org/
diff --git a/debian/mksnapshot b/debian/mksnapshot
index bb6bb98b0..86795b448 100755
--- a/debian/mksnapshot
+++ b/debian/mksnapshot
@@ -9,12 +9,15 @@ dir=uclibc-${version}-cvs${today}
mkdir -p ${topdir}/uclibc-tmp
cd ${topdir}/uclibc-tmp
-#export CVSROOT=':pserver:anonymous@cvs.uclibc.org:/var/cvs'
-#if ! grep -q '^.pserver.anonymous.cvs.uclibc.org..var.cvs' ~/.cvspass
-#then
-# echo "$CVSROOT" 'Ay=0=a%0bZ' >>~/.cvspass
-#fi
-export CVSROOT='ds@cvs.uclibc.org:/var/cvs'
+if [ "$(whoami)" = "ds" ];then
+ export CVSROOT='ds@cvs.uclibc.org:/var/cvs'
+else
+ export CVSROOT=':pserver:anonymous@cvs.uclibc.org:/var/cvs'
+ if ! grep -q '^.pserver.anonymous.cvs.uclibc.org..var.cvs' ~/.cvspass
+ then
+ echo "$CVSROOT" 'Ay=0=a%0bZ' >>~/.cvspass
+ fi
+fi
cvs co -d ${dir} uClibc