summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-02-22 07:28:41 +0000
committerDavid Schleef <ds@schleef.org>2002-02-22 07:28:41 +0000
commite4e0b255f34dbce6630d56375ba7bf339a59ae52 (patch)
treefd4824fcc4b53662799ce4368d7ceec818b1b628 /debian/rules
parent5640182e962a3190dd28eff714cdda9de2d3f877 (diff)
Special rules for mipsel. Force some variables in Config, in
case they're wrong (they are.) Remove Config during clean.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 1f481d2ad..72c028428 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,12 +44,18 @@ build-stamp: debian/control
# Brute force method of getting kernel headers
tar --bzip2 -xf /usr/src/$(kernel_source).tar.bz2 $(kernel_source)/include
+ifneq ($(target),mipsel)
cp extra/Configs/Config.$(target) Config
+else
+ cp extra/Configs/Config.mips Config
+endif
echo '#Debian configuration overrides' >>Config
ifneq ($(target),$(DEB_HOST_GNU_CPU))
echo 'TARGET_ARCH = $(target)' >>Config
echo 'CROSS = $(target)-linux-' >>Config
+else
+ echo 'CROSS = ' >>Config
endif
echo 'DOPIC = true' >>Config
echo 'SYSTEM_DEVEL_PREFIX = /usr' >>Config
@@ -61,6 +67,9 @@ ifeq ($(with_shared_libs),n)
endif
echo 'KERNEL_SOURCE = '`pwd`/$(kernel_source) >>Config
echo 'HAS_MMU = true' >>Config
+ echo 'HAS_FLOATING_POINT = true' >>Config
+ echo 'DO_C99_MATH = true' >>Config
+ echo 'DODEBUG = false' >>Config
$(MAKE)
@@ -78,6 +87,8 @@ clean: debian/control
# Add here commands to clean up after the build process.
-$(MAKE) clean
+ -rm Config
+
dh_clean
install: build debian/control