summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2001-07-17 23:33:15 +0000
committerDavid Schleef <ds@schleef.org>2001-07-17 23:33:15 +0000
commitd00f43f966794b4837603bdfde1a598cf963dd17 (patch)
tree8d15eb51072b1a0a098283c7445d5322a8466a4a /debian/rules
parent0640f1e2db01ea07a25bb01db8cd9618ee1917cd (diff)
Better generation of control, fix up DESTDIR
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 43163582e..ae70b0665 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,11 +29,11 @@ p_dev=libuclibc-dev$(target_suffix)
p_lib=libuclibc0$(target_suffix)
p_gcc=uclibc$(target_suffix)-gcc
-debian/control: debian/control.in
+debian/control: debian/control.in debian/rules
sed s/_TARGET_/$(target_suffix)/ debian/control.in >debian/control
build: build-stamp
-build-stamp:
+build-stamp: debian/control
dh_testdir
# Add here commands to compile the package.
@@ -45,18 +45,19 @@ ifneq ($(target),$(DEB_HOST_GNU_CPU))
echo 'CROSS = $(target)-linux-' >>Config
endif
echo 'DOPIC = true' >>Config
- echo 'PREFIX = $$(DESTDIR)/usr' >>Config
+ echo 'PREFIX = /usr' >>Config
echo 'DEVEL_PREFIX = $$(PREFIX)/$$(TARGET_ARCH)-linux-uclibc' >>Config
- echo 'TARGET_PREFIX = $$(DESTDIR)/' >>Config
+ echo 'TARGET_PREFIX = /' >>Config
ifeq ($(with_shared_libs),n)
echo 'HAVE_SHARED = false' >>Config
endif
+ echo 'KERNEL_SOURCE = /usr/src/kernel-headers-2.4.5' >>Config
$(MAKE)
touch build-stamp
-clean:
+clean: debian/control
dh_testdir
dh_testroot
rm -f build-stamp