summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2002-04-20 22:43:27 +0000
committerDavid Schleef <ds@schleef.org>2002-04-20 22:43:27 +0000
commit6f691fbee6689ff3b5526ed4517fdc8c6bbf12bc (patch)
treec80653d41adbe47708ffed1511dcd6bb60dabc0b /debian/rules
parent79469b53d8783c39417249fb6c0ba6a77779be12 (diff)
Make sure that CROSS="" for native building.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3a9cc4b92..36777ee55 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,6 +41,8 @@ endif
ifneq ($(target),$(DEB_HOST_GNU_CPU))
cross_options = --cross="$(target)-linux-"
+else
+cross_options = --cross=""
endif
p_dev=libuclibc-dev$(target_suffix)
@@ -72,6 +74,14 @@ build-stamp: debian/control
touch $(kernel_source)/include/linux/autoconf.h
+ # Various stupid programs use linux/version.h to find the
+ # Linux version.
+ ( \
+ echo '#define UTS_RELEASE "2.4.16"' \
+ echo '#define LINUX_VERSION_CODE 132112' \
+ echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))' \
+ ) >$(kernel_source)/include/linux/version.h
+
extra/Configs/uClibc_config_fix.pl \
--arch=$(target) \
$(cross_options) \