summaryrefslogtreecommitdiff
path: root/package/gentooinstall/Makefile
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2018-06-01 20:09:51 +0200
committerWaldemar Brodkorb <wbx@openadk.org>2018-06-02 20:11:15 +0200
commit33a9c4a0f92abc42efe6c30c6e0dcd7fb1fd3250 (patch)
tree45ec7c058932e9e9b28bf60ff3504071963b4e3b /package/gentooinstall/Makefile
parente7ab4e78929067524c116d4af10146995751c4ea (diff)
new experimental package gentooinstall
Diffstat (limited to 'package/gentooinstall/Makefile')
-rw-r--r--package/gentooinstall/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/gentooinstall/Makefile b/package/gentooinstall/Makefile
new file mode 100644
index 000000000..251e38a3d
--- /dev/null
+++ b/package/gentooinstall/Makefile
@@ -0,0 +1,29 @@
+# This file is part of the OpenADK project. OpenADK is copyrighted
+# material, please see the LICENCE file in the top-level directory.
+
+include ${ADK_TOPDIR}/rules.mk
+
+PKG_NAME:= gentooinstall
+PKG_VERSION:= 1.0
+PKG_RELEASE:= 1
+PKG_DESCR:= gentoo disk installer
+PKG_SECTION:= base/adk
+PKG_DEPENDS:= mke2fs parted sfdisk dosfstools mksh
+PKG_DEPENDS+= grub grub-tools
+PKG_KDEPENDS:= ext4-fs
+
+NO_DISTFILES:= 1
+
+include ${ADK_TOPDIR}/mk/package.mk
+
+$(eval $(call PKG_template,GENTOOINSTALL,gentooinstall,${PKG_VERSION}-${PKG_RELEASE},${PKG_DEPENDS},${PKG_DESCR},${PKG_SECTION}))
+
+CONFIG_STYLE:= manual
+BUILD_STYLE:= manual
+INSTALL_STYLE:= manual
+
+fwinstall-install:
+ $(INSTALL_DIR) $(IDIR_GENTOOINSTALL)/usr/sbin
+ $(INSTALL_BIN) $(WRKBUILD)/fwinstall $(IDIR_GENTOOINSTALL)/usr/sbin
+
+include ${ADK_TOPDIR}/mk/pkg-bottom.mk